Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-033

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 13 mai 2004
No CERTA-2004-AVI-033-001

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité du client de messagerie Mutt


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-033

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2004-AVI-033-001
Titre Vulnérabilité du client de messagerie Mutt
Date de la première version 12 février 2004
Date de la dernière version 13 mai 2004
Source(s) Bulletins de sécurité de Red Hat
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Exécution de code arbitraire ;
  • déni de service.

2 Systèmes affectés

  • Versions de Mutt antérieures à la version 1.4.2 (stable) ;
  • versions de Mutt antérieures à la version 1.3.28 (instable).

3 Résumé

Une vulnérabilité présente dans le client de messagerie Mutt peut être exploitée afin d'exécuter du code arbitraire sur la plate-forme vulnérable.

4 Description

Mutt est un client de messagerie en mode texte très utilisé sur les plates-formes Linux. Il supporte les protocoles POP3 (Post Office Protocol) et IMAP (Internet Message Access Protocol) pour l'interrogation des serveurs de messagerie.


Une vulnérabilité de type débordement de mémoire est présente dans Mutt.

Un utilisateur mal intentionné peut, par le biais d'un message électronique habilement constitué, exploiter cette vulnérabilité afin d'exécuter du code arbitraire à distance sur la plate-forme cliente avec les privilèges du compte utilisant l'application Mutt.

5 Solution

Les versions de Mutt 1.3.28 et postérieures ne sont pas vulnérables (branche instable).

Pour la branche stable, installer la version 1.4.2 de Mutt :

http://www.mutt.org


ou appliquer le correctif de l'éditeur :

6 Documentation

Gestion détaillée du document

12 février 2004
version initiale.
13 mai 2004
ajout du bulletin de sécurité FreeBSD.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2014-11-21