Marianne ANSSI

CERT-FR

Centre gouvernemental de veille, d'alerte et de réponse aux attaques informatiques

logo ANSSI
Informations utiles

Que faire en cas d'intrusion ?

Les systèmes obsolètes

Liens utiles

 

L'ANSSI recrute

 

 

Les documents du CERT-FR

Publications récentes

Les alertes en cours

Les bulletins d'actualité

Les notes d'information

Année en cours Archive

 

Les Flux RSS du CERT-FR

Flux RSS complet

RSS

Flux RSS des alertes

RSS

Flux RSS SCADA

RSS

 

CERTA-2004-AVI-042

Imprimer ce document

Version PDF

À propos du CERT-FR

Le CERT-FR

Nous contacter

Contact us ( Drapeau anglais )

A propos du site

Communauté CSIRT

Les CSIRT

Le FIRST

L'EGC

 
Archives du CERT-FR

Année 2014 Archive

Année 2013 Archive

Année 2012 Archive

Année 2011 Archive

Année 2010 Archive

Année 2009 Archive

Année 2008 Archive

Année 2007 Archive

Année 2006 Archive

Année 2005 Archive

Année 2004 Archive

Année 2003 Archive

Année 2002 Archive

Année 2001 Archive

Année 2000 Archive

 

S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 06 avril 2004
No CERTA-2004-AVI-042-005

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité du noyau linux


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2004-AVI-042

Gestion du document


Tableau 1: gestion du document
Référence CERTA-2004-AVI-042-005
Titre Vulnérabilité du noyau linux
Date de la première version 18 février 2004
Date de la dernière version 06 avril 2004
Source(s) Bulletin de sécurité isec-0014-mremap-unmap d'Isec
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Elévation de privilèges ;
  • déni de service.

2 Systèmes affectés

  • Linux 2.4.24 et versions antérieures ;
  • Linux 2.6.2 et versions antérieures.

3 Description

Il a été reporté qu'une nouvelle vulnérabilité présente dans l'appel système mremap du noyau Linux pourrait être exploitée par un utilisateur mal intentionné afin d'obtenir les privilèges du super-utilisateur root ou réaliser un déni de service par arrêt brutal du système.

Cet appel système ne nécessitant pas de privilèges particuliers, n'importe quel utilisateur peut tenter d'exploiter cette faille.

Bien que similaire à la vulnérabilité présente dans l'avis CERTA-2004-AVI-002, il s'agit bien d'un nouveau problème de sécurité.

4 Solution

Les versions 2.4.25 et 2.6.3 du noyau Linux corrigent cette vulnérabilité.

5 Documentation

Gestion détaillée du document

18 février 2004
version initiale.
20 février 2004
Ajout références aux bulletins SuSE-SA:2004:005 et DSA-442.
25 février 2004
Ajout référence au bulletin Mandrake MDKSA-2004:015.
27 fevrier 2004
Ajout référence au bulletin SmoothWall SWP-2004.002.
05 avril 2004
Ajout références aux bulletins Debian DSA-470 et Gentoo GLSA 200403-02.
06 avril 2004
Ajout références aux bulletins de VMware pour ESX Server.


CERTA
2014-01-17
Premier Ministre / Secrétariat Général de la Défense et de la Sécurité Nationale / Agence nationale de la sécurité des systèmes d'information webmestre Dernière mise à jour : le 2014-08-22