S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 01 mars 2005
No CERTA-2005-AVI-006-004

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité de KDE


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2005-AVI-006

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2005-AVI-006-004
Titre Vulnérabilité de KDE
Date de la première version 05 janvier 2005
Date de la dernière version 01 mars 2005
Source(s) Bulletin de sécurité de KDE
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

  • Usurpation d'identité ;
  • atteinte à l'intégrité des données.

2 Systèmes affectés

KDE 3.3.2 et version antérieures.

3 Description

KDE est un environnement graphique utilisé sur les systèmes Unix et Linux.


Une vulnérabilité est présente dans le traitement des URL de type ftp:// rendant possible l'injection de commandes dans une session FTP.

En forcant l'utilisateur d'un programme exploitant le composant KDE kio_ftp (tel le navigateur Konqueror) à consulter une URL habilement constituée, il est alors possible de réaliser des attaques par rebond sur certains services réseau (SMTP par exemple).

4 Solution

Se référer au bulletin de sécurité de l'éditeur (cf. section Documentation) pour l'obtention des correctifs.

5 Documentation

Gestion détaillée du document

05 janvier 2005
version initiale.
11 février 2005
ajout des références aux bulletins de sécurité Debian, Gentoo et RedHat.
17 février 2005
ajout de la référence au bulletin de sécurité RHSA-2005:065 de RedHat.
18 février 2005
ajout de la référence au bulletin de sécurité MDKSA-2005:045 de Mandrake.
01 mars 2005
ajout de la référence au bulletin de sécurité NetBSD.


CERTA
2014-01-17