S . G . D . S . N
Agence nationale
de la sécurité des
systèmes d'information

République Française Paris, le 12 avril 2012
No CERTA-2012-AVI-210-002

Affaire suivie par :

CERTA

AVIS DU CERTA

Objet : Vulnérabilité dans Samba


Conditions d'utilisation de ce document : http://www.certa.ssi.gouv.fr/certa/apropos.html
Dernière version de ce document : http://www.certa.ssi.gouv.fr/site/CERTA-2012-AVI-210

Gestion du document


Tableau 1: Gestion du document
Référence CERTA-2012-AVI-210-002
Titre Vulnérabilité dans Samba
Date de la première version 11 avril 2012
Date de la dernière version 13 avril 2012
Source(s) Bulletin de sécurité Samba du 10 avril 2012
Pièce(s) jointe(s) Aucune

Une gestion de version détaillée se trouve à la fin de ce document.

1 Risque

Exécution de code arbitraire à distance.

2 Systèmes affectés

  • Samba 3.6.x jusqu'à la version 3.6.3 ;
  • Samba 3.5.x jusqu'à la version 3.5.13 ;
  • Samba 3.4.x jusqu'à la version 3.4.15.

3 Résumé

Une vulnérabilité a été corrigée dans Samba. Cette vulnérabilité est un débordement de tampon de type heap overflow. Elle peut être exploitée au moyen d'un message RPC, sans être authentifié et permet d'exécuter un code arbitraire à distance avec les droits root.

4 Solution

Les versions 3.6.4, 3.5.14 et 3.4.16 de Samba corrigent ce problème.

Se référer au bulletin de sécurité de l'éditeur pour l'obtention des correctifs (cf. section Documentation).

5 Documentation

Gestion détaillée du document

11 avril 2012
version initiale.
12 avril 2012
ajout des références aux bulletins Mandriva et RedHat.
13 avril 2012
précision sur les versions concernées et ajout des références aux bulletins Debian et Ubuntu.


CERTA
2014-01-17